{"_id":"59fcb6985f893200262cfee6","project":"55faf11ba62ba1170021a9a7","version":{"_id":"55faf11ba62ba1170021a9aa","project":"55faf11ba62ba1170021a9a7","__v":40,"createdAt":"2015-09-17T16:58:03.490Z","releaseDate":"2015-09-17T16:58:03.490Z","categories":["55faf11ca62ba1170021a9ab","55faf8f4d0e22017005b8272","55faf91aa62ba1170021a9b5","55faf929a8a7770d00c2c0bd","55faf932a8a7770d00c2c0bf","55faf94b17b9d00d00969f47","55faf958d0e22017005b8274","55faf95fa8a7770d00c2c0c0","55faf96917b9d00d00969f48","55faf970a8a7770d00c2c0c1","55faf98c825d5f19001fa3a6","55faf99aa62ba1170021a9b8","55faf99fa62ba1170021a9b9","55faf9aa17b9d00d00969f49","55faf9b6a8a7770d00c2c0c3","55faf9bda62ba1170021a9ba","5604570090ee490d00440551","5637e8b2fbe1c50d008cb078","5649bb624fa1460d00780add","5671974d1b6b730d008b4823","5671979d60c8e70d006c9760","568e8eef70ca1f0d0035808e","56d0a2081ecc471500f1795e","56d4a0adde40c70b00823ea3","56d96b03dd90610b00270849","56fbb83d8f21c817002af880","573c811bee2b3b2200422be1","576bc92afb62dd20001cda85","5771811e27a5c20e00030dcd","5785191af3a10c0e009b75b0","57bdf84d5d48411900cd8dc0","57ff5c5dc135231700aed806","5804caf792398f0f00e77521","58458b4fba4f1c0f009692bb","586d3c287c6b5b2300c05055","58ef66d88646742f009a0216","58f5d52d7891630f00fe4e77","59a555bccdbd85001bfb1442","5a2a81f688574d001e9934f5","5b080c8d7833b20003ddbb6f"],"is_deprecated":false,"is_hidden":false,"is_beta":true,"is_stable":true,"codename":"","version_clean":"1.0.0","version":"1.0"},"category":{"_id":"57bdf84d5d48411900cd8dc0","version":"55faf11ba62ba1170021a9aa","__v":0,"project":"55faf11ba62ba1170021a9a7","sync":{"url":"","isSync":false},"reference":false,"createdAt":"2016-08-24T19:41:01.302Z","from_sync":false,"order":28,"slug":"api-hub","title":"API Hub"},"user":"575e85ac41c8ba0e00259a44","githubsync":"","__v":0,"parentDoc":null,"updates":[],"next":{"pages":[],"description":""},"createdAt":"2017-11-03T18:34:00.400Z","link_external":false,"link_url":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":8,"body":"##Overview\n\nThe Seven Bridges API Java client is now available on GitHub at [https://github.com/sbg/sevenbridges-java](https://github.com/sbg/sevenbridges-java). \n\nOn this page, learn how to install Seven Bridges Java. Then follow the [Java library Quickstart](doc:java-library-quickstart) to get started.\n\n<div align=\"right\"><a href=\"#top\">top</a></div>\n\n##Installation\n\nGet started with Seven Bridges Java using [Maven](https://maven.apache.org/) to add the following lines to the `<dependencies>` section of your `pom.xml` file.\n[block:code]\n{\n  \"codes\": [\n    {\n      \"code\": \"```\\n    <dependency>\\n      <groupId>com.sevenbridges.apiclient</groupId>\\n      <artifactId>sevenbridges-java-api</artifactId>\\n      <version>0.5.0</version>\\n    </dependency>\\n    <dependency>\\n      <groupId>com.sevenbridges.apiclient</groupId>\\n      <artifactId>sevenbridges-java-httpclient</artifactId>\\n      <version>0.5.0</version>\\n      <scope>runtime</scope>\\n    </dependency>\\n```\",\n      \"language\": \"text\"\n    }\n  ]\n}\n[/block]\nTo install using [Gradle](https://gradle.org/), add the following to the dependencies section of your `build.gradle` file:\n[block:code]\n{\n  \"codes\": [\n    {\n      \"code\": \"```\\ndependencies {\\n  compile group: 'com.sevenbridges.apiclient', name: 'sevenbridges-java-api', version: '0.5.0'\\n  runtime group: 'com.sevenbridges.apiclient', name: 'sevenbridges-java-httpclient', version: '0.5.0'\\n}\\n```\\n\",\n      \"language\": \"text\"\n    }\n  ]\n}\n[/block]\n<div align=\"right\"><a href=\"#top\">top</a></div>\n\n##Resources\n* [Java library Quickstart](doc:java-library-quickstart) \n* [Seven Bridges Java on GitHub](https://github.com/sbg/sevenbridges-java)\n\n<div align=\"right\"><a href=\"#top\">top</a></div>","excerpt":"","slug":"api-java-library","type":"basic","title":"Java library"}
##Overview The Seven Bridges API Java client is now available on GitHub at [https://github.com/sbg/sevenbridges-java](https://github.com/sbg/sevenbridges-java). On this page, learn how to install Seven Bridges Java. Then follow the [Java library Quickstart](doc:java-library-quickstart) to get started. <div align="right"><a href="#top">top</a></div> ##Installation Get started with Seven Bridges Java using [Maven](https://maven.apache.org/) to add the following lines to the `<dependencies>` section of your `pom.xml` file. [block:code] { "codes": [ { "code": "```\n <dependency>\n <groupId>com.sevenbridges.apiclient</groupId>\n <artifactId>sevenbridges-java-api</artifactId>\n <version>0.5.0</version>\n </dependency>\n <dependency>\n <groupId>com.sevenbridges.apiclient</groupId>\n <artifactId>sevenbridges-java-httpclient</artifactId>\n <version>0.5.0</version>\n <scope>runtime</scope>\n </dependency>\n```", "language": "text" } ] } [/block] To install using [Gradle](https://gradle.org/), add the following to the dependencies section of your `build.gradle` file: [block:code] { "codes": [ { "code": "```\ndependencies {\n compile group: 'com.sevenbridges.apiclient', name: 'sevenbridges-java-api', version: '0.5.0'\n runtime group: 'com.sevenbridges.apiclient', name: 'sevenbridges-java-httpclient', version: '0.5.0'\n}\n```\n", "language": "text" } ] } [/block] <div align="right"><a href="#top">top</a></div> ##Resources * [Java library Quickstart](doc:java-library-quickstart) * [Seven Bridges Java on GitHub](https://github.com/sbg/sevenbridges-java) <div align="right"><a href="#top">top</a></div>