{"_id":"5c76b2cbffa12f001e3a4a39","project":"55faf11ba62ba1170021a9a7","version":{"_id":"55faf11ba62ba1170021a9aa","project":"55faf11ba62ba1170021a9a7","__v":44,"createdAt":"2015-09-17T16:58:03.490Z","releaseDate":"2015-09-17T16:58:03.490Z","categories":["55faf11ca62ba1170021a9ab","55faf8f4d0e22017005b8272","55faf91aa62ba1170021a9b5","55faf929a8a7770d00c2c0bd","55faf932a8a7770d00c2c0bf","55faf94b17b9d00d00969f47","55faf958d0e22017005b8274","55faf95fa8a7770d00c2c0c0","55faf96917b9d00d00969f48","55faf970a8a7770d00c2c0c1","55faf98c825d5f19001fa3a6","55faf99aa62ba1170021a9b8","55faf99fa62ba1170021a9b9","55faf9aa17b9d00d00969f49","55faf9b6a8a7770d00c2c0c3","55faf9bda62ba1170021a9ba","5604570090ee490d00440551","5637e8b2fbe1c50d008cb078","5649bb624fa1460d00780add","5671974d1b6b730d008b4823","5671979d60c8e70d006c9760","568e8eef70ca1f0d0035808e","56d0a2081ecc471500f1795e","56d4a0adde40c70b00823ea3","56d96b03dd90610b00270849","56fbb83d8f21c817002af880","573c811bee2b3b2200422be1","576bc92afb62dd20001cda85","5771811e27a5c20e00030dcd","5785191af3a10c0e009b75b0","57bdf84d5d48411900cd8dc0","57ff5c5dc135231700aed806","5804caf792398f0f00e77521","58458b4fba4f1c0f009692bb","586d3c287c6b5b2300c05055","58ef66d88646742f009a0216","58f5d52d7891630f00fe4e77","59a555bccdbd85001bfb1442","5a2a81f688574d001e9934f5","5b080c8d7833b20003ddbb6f","5c222bed4bc358002f21459a","5c22412594a2a5005cc9e919","5c41ae1c33592700190a291e","5c8a525e2ba7b2003f9b153c"],"is_deprecated":false,"is_hidden":false,"is_beta":true,"is_stable":true,"codename":"","version_clean":"1.0.0","version":"1.0"},"category":{"_id":"58f5d52d7891630f00fe4e77","project":"55faf11ba62ba1170021a9a7","version":"55faf11ba62ba1170021a9aa","__v":0,"sync":{"url":"","isSync":false},"reference":false,"createdAt":"2017-04-18T08:58:21.978Z","from_sync":false,"order":38,"slug":"data-cruncher","title":"DATA CRUNCHER"},"user":"5767bc73bb15f40e00a28777","__v":0,"parentDoc":null,"updates":[],"next":{"pages":[],"description":""},"createdAt":"2019-02-27T15:54:51.346Z","link_external":false,"link_url":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":4,"body":"This page provides a brief description of the RStudio IDE and its commonly used options. \n[block:callout]\n{\n  \"type\": \"info\",\n  \"body\": \"RStudio implementation in Data Cruncher is currently in the beta stage. Please report any issues to [support:::at:::sbgenomics.com](mailto:support@sbgenomics.com).\"\n}\n[/block]\n## The RStudio Interface\nOnce you have set up and started an analysis using RStudio as the editor, the main editor screen is displayed. To start entering your R code, select **File** > **New File** from the main menu, and then select the most suitable file type. Alternatively, you can type your code directly in the **Console** pane.\n\nThis is the default RStudio screen setup with an R file open for editing:\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/a6acb16-rstudio-quick-reference-1.png\",\n        \"rstudio-quick-reference-1.png\",\n        1440,\n        687,\n        \"#f7f5ef\"\n      ]\n    }\n  ]\n}\n[/block]\n1. **Main menu** - complete set of options available in the RStudio IDE.\n2. **Toolbar** - contains buttons for commonly used commands in RStudio.\n3. **Source** - the main editor window where you can create or open your R scripts/notebooks.\n4. **Environment**, **History**, **Connections**:\n    a. **Environment** - shows all active objects created during your session.\n    b. **History** - keeps a record of all previously entered commands.\n    c. **Connections** - shows you all the connections you have made to supported data sources, and lets you know which connections are currently active. \n5. **Console** - allows you to type R commands directly and see the output.\n6. **Files**, **Plots**, **Packages**, **Help**, **Viewer**:\n    a. **Files** - shows all files and folders in your default workspace.\n    b. **Plots** - shows all your graphs.\n    c. **Packages** - lists a series of packages or add-ons needed to run certain processes.\n    d. **Help** - provides additional learning and reference resources.\n    e. **Viewer** - is similar to the **Plots** tab, but displays HTML output generated by some R functions or Shiny apps.\n7. **Shut down** - Stop the analysis and leave RStudio.\n\nAvailable panes and the appearance of the RStudio environment can be customized using the following options:\n\n  * from the **View** menu on the main menu bar,\n  * using window resizing options in the top-right corner of each window and\n  * by dragging the borders between the panes.","excerpt":"","slug":"rstudio-quick-reference","type":"basic","title":"RStudio quick reference"}

RStudio quick reference


This page provides a brief description of the RStudio IDE and its commonly used options. [block:callout] { "type": "info", "body": "RStudio implementation in Data Cruncher is currently in the beta stage. Please report any issues to [support@sbgenomics.com](mailto:support@sbgenomics.com)." } [/block] ## The RStudio Interface Once you have set up and started an analysis using RStudio as the editor, the main editor screen is displayed. To start entering your R code, select **File** > **New File** from the main menu, and then select the most suitable file type. Alternatively, you can type your code directly in the **Console** pane. This is the default RStudio screen setup with an R file open for editing: [block:image] { "images": [ { "image": [ "https://files.readme.io/a6acb16-rstudio-quick-reference-1.png", "rstudio-quick-reference-1.png", 1440, 687, "#f7f5ef" ] } ] } [/block] 1. **Main menu** - complete set of options available in the RStudio IDE. 2. **Toolbar** - contains buttons for commonly used commands in RStudio. 3. **Source** - the main editor window where you can create or open your R scripts/notebooks. 4. **Environment**, **History**, **Connections**: a. **Environment** - shows all active objects created during your session. b. **History** - keeps a record of all previously entered commands. c. **Connections** - shows you all the connections you have made to supported data sources, and lets you know which connections are currently active. 5. **Console** - allows you to type R commands directly and see the output. 6. **Files**, **Plots**, **Packages**, **Help**, **Viewer**: a. **Files** - shows all files and folders in your default workspace. b. **Plots** - shows all your graphs. c. **Packages** - lists a series of packages or add-ons needed to run certain processes. d. **Help** - provides additional learning and reference resources. e. **Viewer** - is similar to the **Plots** tab, but displays HTML output generated by some R functions or Shiny apps. 7. **Shut down** - Stop the analysis and leave RStudio. Available panes and the appearance of the RStudio environment can be customized using the following options: * from the **View** menu on the main menu bar, * using window resizing options in the top-right corner of each window and * by dragging the borders between the panes.