secondary files not loaded when in batch runs

Posted in Add your tools by filippo_martignano Tue Jul 10 2018 17:18:08 GMT+0000 (UTC)·3·Viewed 97 times

Hi! I have a tool which analyzes .bam files and requires .bai files as secondary files. The secondary files settings are ok as the tool works well when a run on a single file is performed. However, when i try to make a batch task, it doesn't work and the error log says "unable to find index file for example.bam" or something like this. Is it a known bug? is there a way to overcome this problem? Thanks a lot!
Natasa Bezmarevic
July 11, 2018

Hi Filippo,

Could you please provide the link for mentioned task?

It often happens that one of the bai files is missing or that the tool expects secondary file in example.bam.bai name format and you have it in example.bai name format.

However, we are not aware of such issue and we will come back to you as soon as we check the task details.

Best
Natasa

filippo_martignano
July 12, 2018

Hi Natasa!
Thank you very much.

I've checked the extension of my index files (.bam.bai or .bai or whatever) and everything is fine, indeed exactly the same tool works fine if used in "single" mode.

Right now I'm running a long analysis with a modified version of the tool in order to get rid of the problem, but as soon as my analysis is finished I will contact you again with the link of the task etc. so you will be able to check the issue.

I belive I will be ready in a couple of days.

See you soon, and thanks a lot!
Filippo.

Natasa Bezmarevic
July 12, 2018

You're welcome Filippo.

Let us know if you need our assistance, we are happy to help!

Have a nice day!
Natasa

  
Markdown is allowed